User Tools

Site Tools


fw1000_and_mm

Micro-Manager and Filterwheel

This Technical note is to document the known issue when connecting micro-manager(MM) with ASI's filter wheel and work around for it.

On Startup MicroManager does the following:

  • First MM does is to issue serial command VB 6 to set the controller in verbose mode 6, where 0> or 1> prompt isn't given.
  • Next it selects the filterwheel being added FW0 or FW1
  • Then queries the firmware version with VN command.
  • Next sets spin mode to 0 with SF0 command
  • Then queries the controller for number of filter positions with NF command
  • Next queries the spin mode again with SF to make sure spin mode is idle.
  • Then queries the status of the controller with busy command ? . If the controller replies with 0 indicating controller isn't busy, then MM issues MP 0 command to move wheel to position 0.
  • Often the reply to ? isn't as clean as a 0 . Then MM issues SF0 again , followed by Home HO command. Then it polls busy ? command every 20 millisec until it gets a 0 as reply. Does it atleast a 100 times. If it never gets 0 as a reply, then it gives up gives “Filter wheel doesn't appear to be connected” error# 10030.
  • Some times Home HO command causes another error. HO command replies with an echo HO . Because of legacy this command isn't terminated and a time out is used by MM to wait for the reply to come. If the reply is delayed and the timer runs out and doesn't get the reply for HO , MM gives a “Unrecognized serial answer from ASI device” error# 10009 instead.
  • The fix, on startup of controller, before connecting to MM , press the NEXT button a couple of times, this clear up any 11 errors. So when MM queries with busy ? command, it gets the 0 reply right away and it avoids the whole HO command issue.
fw1000_and_mm.txt · Last modified: 2019/04/18 23:34 (external edit)